Image

Palomar elite 300

This is the place to ask questions about linear amplifiers, or power supplies

Moderator: JR Moderator

User avatar
Mtn Lynx
Donor
Donor
Posts: 429
Joined: Sunday, 11 September 2016, 1:00 AM
Radio: Anytone AT 6666
Antenna: A99/Wire dipole
Name: Cletus
Location: Western AK

Palomar elite 300

Post by Mtn Lynx » Friday, 10 February 2017, 0:14 AM

I bought a Palomar elite 300 a couple of months ago. It worked good for a while, but last month while I was doing a radio check with my 959. I could tell it was dying out it started causing some static noise on my radio. It was putting out about 250 watts on am and about 275 ssb when I first got it, after something gave out, it puts out 150 watts on am and about 160 on ssb. Do I need to replace a transistor? There was always a delay with the preamp. My 225 never has a delay.

My Palomar 225 is functioning perfectly flawless since I got it in November. I have driven it harder than the 300. It doesn't put out as much wattage but has not given me any trouble.
\m/ >.< \m/
Anytone AT 6666
Galaxy DX 959
Galaxy DX 2517
Cobra 148 GTL
1/2 wave Dipole
Solarcon A99
TWRC Member: WR223




User avatar
sonoma
Donor
Donor
Posts: 1324
Joined: Sunday, 02 April 2006, 14:10 PM
Location: Oklahoma

Re: Palomar elite 300

Post by sonoma » Friday, 10 February 2017, 4:00 AM

did not find a schematic for the 300 elite. maybe one of these is the same if it will help.cb tricks has a lot of amp manuals if this will help.not sure if it is a transister or tube amp, so also here is a trouble shooting page for texas star trans amps which will work on any brand to test. well it will not let me load the texas star amp repair. if you want it PM me your email address.

http://www.cbtricks.com/Amp/palomar/index.htm" onclick="window.open(this.href);return false;

User avatar
Mtn Lynx
Donor
Donor
Posts: 429
Joined: Sunday, 11 September 2016, 1:00 AM
Radio: Anytone AT 6666
Antenna: A99/Wire dipole
Name: Cletus
Location: Western AK

Re: Palomar elite 300

Post by Mtn Lynx » Friday, 10 February 2017, 11:37 AM

thanks Sonoma, the 300 has transistors. I'll work on my amps this weekend
\m/ >.< \m/
Anytone AT 6666
Galaxy DX 959
Galaxy DX 2517
Cobra 148 GTL
1/2 wave Dipole
Solarcon A99
TWRC Member: WR223



User avatar
MDYoungblood
Moderator
Moderator
Posts: 7317
Joined: Saturday, 12 June 2010, 19:05 PM
Logged in via: iPad
Radio: Uniden Washington
Antenna: Avanti Sigma II
Name: Greg
Location: Baltimore, MD

Re: Palomar elite 300

Post by MDYoungblood » Friday, 10 February 2017, 13:10 PM

Pop it open and take some pics.

3's

Greg
ImageImageImage


"321, the Middle of Maryland"

23 AM "WORLD Image WIDE" 38 LSB

Strong Supporter of America's Original Homeland Security Act
The Second Amendment


Base
Uniden Washington
Mobile
Texas Ranger TR-696FD1C
Handheld
Maxon HCB-40WX
Antennas
Avanti Sigma II
Homemade Full Wave Loop
Homemade 1/2 wave Dipole
Hustler 102" SS Whip and Hustler Ball Mount

Official Moderator - CBRT Complaint Department



User avatar
Mtn Lynx
Donor
Donor
Posts: 429
Joined: Sunday, 11 September 2016, 1:00 AM
Radio: Anytone AT 6666
Antenna: A99/Wire dipole
Name: Cletus
Location: Western AK

Re: Palomar elite 300

Post by Mtn Lynx » Friday, 10 February 2017, 15:55 PM

will take pics later tonite.
\m/ >.< \m/
Anytone AT 6666
Galaxy DX 959
Galaxy DX 2517
Cobra 148 GTL
1/2 wave Dipole
Solarcon A99
TWRC Member: WR223




User avatar
sonoma
Donor
Donor
Posts: 1324
Joined: Sunday, 02 April 2006, 14:10 PM
Location: Oklahoma

Re: Palomar elite 300

Post by sonoma » Friday, 10 February 2017, 16:16 PM

I emailed you the texas star trouble shooting guide, did you get it in a email as of yet. let me know in case I need to resend it to you

User avatar
Mtn Lynx
Donor
Donor
Posts: 429
Joined: Sunday, 11 September 2016, 1:00 AM
Radio: Anytone AT 6666
Antenna: A99/Wire dipole
Name: Cletus
Location: Western AK

Re: Palomar elite 300

Post by Mtn Lynx » Friday, 10 February 2017, 16:29 PM

got it. thanks again.

yeehaa my profile advanced to skipshooter as of now.
feels just like a video game. lol

-- Friday, 10 February 2017, 16:24 PM --

https://postimg.org/image/rg7zw3plz/" onclick="window.open(this.href);return false;
Having trouble posting but maybe this will work
\m/ >.< \m/
Anytone AT 6666
Galaxy DX 959
Galaxy DX 2517
Cobra 148 GTL
1/2 wave Dipole
Solarcon A99
TWRC Member: WR223



User avatar
PA629
Wordwide & Qualified
Wordwide & Qualified
Posts: 868
Joined: Tuesday, 17 October 2006, 23:49 PM
Location: NW PA

Re: Palomar elite 300

Post by PA629 » Saturday, 11 February 2017, 6:58 AM

I have one. It's one of the typical El Cheapo Palomar clones that are on the market, nothing more, nothing less. Just a typical 2x1446 amp. Try this for the schemo:

http://www.cbtricks.com/Amp/palomar_oth ... pe%20B.gif" onclick="window.open(this.href);return false;


At least this is what the one I have is.
Base: Galaxy DX2517, D104 Silver Eagle w/W2ENY element, SB 220, Imax 2000, 4 element quad
Mobile: Galaxy 95T2, Astatic 575-M6, Sirio P-5000 Performer, Unmentionable 4x2879



User avatar
Mtn Lynx
Donor
Donor
Posts: 429
Joined: Sunday, 11 September 2016, 1:00 AM
Radio: Anytone AT 6666
Antenna: A99/Wire dipole
Name: Cletus
Location: Western AK

Re: Palomar elite 300

Post by Mtn Lynx » Tuesday, 21 March 2017, 22:51 PM

My 300 started spitting out some watts today. I guess my preamp burned out. All I did was put it back together and checked it out. Working fine now minus the preamp.
\m/ >.< \m/
Anytone AT 6666
Galaxy DX 959
Galaxy DX 2517
Cobra 148 GTL
1/2 wave Dipole
Solarcon A99
TWRC Member: WR223




Post Reply Previous topicNext topic

Who is online

Users browsing this forum: No registered users and 6 guests