Image

Galaxy Saturn Turbo doing a strange thing

A place to ask questions about base setups.

Moderator: JR Moderator

User avatar
Tinman590
Donor
Donor
Posts: 643
Joined: Sunday, 11 January 2009, 18:26 PM
Radio: Icom and RCI-2980
Name: Andy
Location: North Carolina
Contact:

Galaxy Saturn Turbo doing a strange thing

Post by Tinman590 » Monday, 22 February 2016, 6:00 AM

I have a Saturn Turbo, the volume suddenly goes way up on receiving stations. The tx is fine. To turn it down to a reasonable level I have to use the rf gain. I was thinkin the volume pot to keep things simple. Turned all the way down the radio is still pretty loud then all of a sudden will go back to normal. Just wondering if there is an obvious thing someone else knew about. Thanks in advance Tinman 8)
RCI-2980WX
ELKIN 6 (6dq6) sometimes a driver
Henry Radio 2k2
Imax 2000
4 element maco
RCI-2950 twin tube modulator
Cobra 2000
Washington
A bunch of other stuff




User avatar
MDYoungblood
Moderator
Moderator
Posts: 7207
Joined: Saturday, 12 June 2010, 19:05 PM
Logged in via: iPad
Radio: Uniden Washington
Antenna: Avanti Sigma II
Name: Greg
Location: Baltimore, MD

Re: Galaxy Saturn Turbo doing a strange thing

Post by MDYoungblood » Monday, 22 February 2016, 12:28 PM

The increase in volume says to me there is an increase in voltage happening, could be the regulator going bad. Do things like the meter read higher and lights get brighter? Goes back to normal after transmitting? How old is the radio?

3's

Greg
ImageImageImage


"321, the Middle of Maryland"

23 AM "WORLD Image WIDE" 38 LSB

Strong Supporter of America's Original Homeland Security Act
The Second Amendment


Base
Uniden Washington
Mobile
Texas Ranger TR-696FD1C
Handheld
Maxon HCB-40WX
Antennas
Avanti Sigma II
Homemade Full Wave Loop
Homemade 1/2 wave Dipole
Hustler 102" SS Whip and Hustler Ball Mount

Official Moderator - CBRT Complaint Department



User avatar
sonoma
Donor
Donor
Posts: 1305
Joined: Sunday, 02 April 2006, 14:10 PM
Location: Oklahoma

Re: Galaxy Saturn Turbo doing a strange thing

Post by sonoma » Monday, 22 February 2016, 13:51 PM

MD may be on to something here. unplug the internal power supply and hook it to a external power supply and see if it still does that. you should have an external 3 pin plug on the back of the radio for 12 volts.

User avatar
MDYoungblood
Moderator
Moderator
Posts: 7207
Joined: Saturday, 12 June 2010, 19:05 PM
Logged in via: iPad
Radio: Uniden Washington
Antenna: Avanti Sigma II
Name: Greg
Location: Baltimore, MD

Re: Galaxy Saturn Turbo doing a strange thing

Post by MDYoungblood » Monday, 22 February 2016, 14:43 PM

I believe that radio has the same board as the 2995, don't think it has a 13.8v jack on the back to power the radio (the 12v RCA jack is to power a fan). The PS inside is a linear type and the regulator is on a small board attached to the back. Some tech's jack up the voltage to increase the radio's wattage, doing this causes a world of problems, check the voltage there and set it back to 13.6 to 13.8 volts, hopefully it hasn't fried the regulating transistor.

3's

Greg
ImageImageImage


"321, the Middle of Maryland"

23 AM "WORLD Image WIDE" 38 LSB

Strong Supporter of America's Original Homeland Security Act
The Second Amendment


Base
Uniden Washington
Mobile
Texas Ranger TR-696FD1C
Handheld
Maxon HCB-40WX
Antennas
Avanti Sigma II
Homemade Full Wave Loop
Homemade 1/2 wave Dipole
Hustler 102" SS Whip and Hustler Ball Mount

Official Moderator - CBRT Complaint Department



User avatar
sonoma
Donor
Donor
Posts: 1305
Joined: Sunday, 02 April 2006, 14:10 PM
Location: Oklahoma

Re: Galaxy Saturn Turbo doing a strange thing

Post by sonoma » Monday, 22 February 2016, 15:31 PM

I forgot that the saturn brands did not have the power plug for 12 volts on them. I remember I had to bypass the main power supply to see if the problem was in the power supply. sorry about that.


User avatar
MDYoungblood
Moderator
Moderator
Posts: 7207
Joined: Saturday, 12 June 2010, 19:05 PM
Logged in via: iPad
Radio: Uniden Washington
Antenna: Avanti Sigma II
Name: Greg
Location: Baltimore, MD

Re: Galaxy Saturn Turbo doing a strange thing

Post by MDYoungblood » Monday, 22 February 2016, 16:22 PM

It would be nice if they did, think the reason is the amplifier needing 30a to power it and I am wrong about it being a 2950 board, (I said 2995) but it is a ranger board. I'm totally not sure if the later Galaxy model has a switching supply in it or not, I think the Turbo's were discontinued in 2006 before the switching supplies started being used.

3's

Greg
ImageImageImage


"321, the Middle of Maryland"

23 AM "WORLD Image WIDE" 38 LSB

Strong Supporter of America's Original Homeland Security Act
The Second Amendment


Base
Uniden Washington
Mobile
Texas Ranger TR-696FD1C
Handheld
Maxon HCB-40WX
Antennas
Avanti Sigma II
Homemade Full Wave Loop
Homemade 1/2 wave Dipole
Hustler 102" SS Whip and Hustler Ball Mount

Official Moderator - CBRT Complaint Department



User avatar
sonoma
Donor
Donor
Posts: 1305
Joined: Sunday, 02 April 2006, 14:10 PM
Location: Oklahoma

Re: Galaxy Saturn Turbo doing a strange thing

Post by sonoma » Monday, 22 February 2016, 16:38 PM

i have seen one over the years doing what you are talking about. the power supply would go way above 12.8 volts and cause the thing to act up and volume to get loud. so that is a good possibility. will just have to watch it and see what the voltage is doing. he could just hook a volt meter to it for a while to see if the voltage goes way up when it acts up.

User avatar
Tinman590
Donor
Donor
Posts: 643
Joined: Sunday, 11 January 2009, 18:26 PM
Radio: Icom and RCI-2980
Name: Andy
Location: North Carolina
Contact:

Re: Galaxy Saturn Turbo doing a strange thing

Post by Tinman590 » Tuesday, 23 February 2016, 5:42 AM

Thanks for the replies men. The volume seems to be the only thing affected. Radio talks great and receives great. I would say the radio is 15 years old plus. I bought it second hand for my step dad to talk on. Any more info on what to check out would be awesome. Also where to adjust voltage. Voltage does sound like a culprit though
RCI-2980WX
ELKIN 6 (6dq6) sometimes a driver
Henry Radio 2k2
Imax 2000
4 element maco
RCI-2950 twin tube modulator
Cobra 2000
Washington
A bunch of other stuff



User avatar
sonoma
Donor
Donor
Posts: 1305
Joined: Sunday, 02 April 2006, 14:10 PM
Location: Oklahoma

Re: Galaxy Saturn Turbo doing a strange thing

Post by sonoma » Tuesday, 23 February 2016, 11:32 AM

it should show it in the service manual.

User avatar
redlght
Donor
Donor
Posts: 555
Joined: Wednesday, 23 January 2013, 17:07 PM
Radio: a few diifferent
Antenna: astroplane

Re: Galaxy Saturn Turbo doing a strange thing

Post by redlght » Tuesday, 23 February 2016, 12:04 PM

I had one do that and it was a dirty relay in the 100watt amp board on back of radio try tapping back there when is goes low see if it brings it back up high or try keying the mic see if that makes it change some times.

User avatar
Tinman590
Donor
Donor
Posts: 643
Joined: Sunday, 11 January 2009, 18:26 PM
Radio: Icom and RCI-2980
Name: Andy
Location: North Carolina
Contact:

Re: Galaxy Saturn Turbo doing a strange thing

Post by Tinman590 » Tuesday, 23 February 2016, 15:44 PM

Will do redlight thanks. The audio gets really loud instead of low. It comes and goes, maybe an hour to 5 days before it acts up. I love radios
RCI-2980WX
ELKIN 6 (6dq6) sometimes a driver
Henry Radio 2k2
Imax 2000
4 element maco
RCI-2950 twin tube modulator
Cobra 2000
Washington
A bunch of other stuff




Post Reply Previous topicNext topic

Who is online

Users browsing this forum: MDYoungblood and 2 guests