Image

Galaxy 2517

Have some other technical questions can't find the answer for? Come in and ask them here.

Moderator: JR Moderator

User avatar
smoke blower
Skipshooter
Skipshooter
Posts: 341
Joined: Sunday, 26 June 2011, 17:05 PM

Re: Galaxy 2517

Post by smoke blower » Sunday, 04 June 2017, 16:15 PM

Ok I will try that and let you know I think the best thing is to probably order a new power supply board there only like $20 to $30 that way Everything is new. I won't be able to work on the radio until Friday I know I will be late most of the week getting home. I will try the caps first and see what happens before I order a new power supply board. Thanks for all your help and I opoligize for you having problems getting with me to work on it. I can't do much Monday threw Thursdays in the shop to work on stuff I only have Friday night , Saturday night and Sunday to work on stuff in between things going on here. I usually get on here some during work to see what is going on but I hope soon to spend more time on here if I get my new job. Thanks again Sonoma and everyone else for the help.

[ Post made via Android ] Image


User avatar
smoke blower
Skipshooter
Skipshooter
Posts: 341
Joined: Sunday, 26 June 2011, 17:05 PM

Re: Galaxy 2517

Post by smoke blower » Sunday, 04 June 2017, 16:23 PM



[ Post made via Android ] Image

User avatar
sonoma
Donor
Donor
Posts: 1214
Joined: Sunday, 02 April 2006, 14:10 PM
Location: Oklahoma

Re: Galaxy 2517

Post by sonoma » Sunday, 04 June 2017, 17:38 PM

the transformer seems to be good. most put out the 22 volts before it goes through the rectifier and transistors. I would check the trans and caps as the galaxy service paper work I left for you.

[ Post made via Linux Laptop ] Image

User avatar
smoke blower
Skipshooter
Skipshooter
Posts: 341
Joined: Sunday, 26 June 2011, 17:05 PM

Re: Galaxy 2517

Post by smoke blower » Sunday, 04 June 2017, 17:50 PM

Ok I did pull the transistors tr601 and tr602 and they tested good so I am not sure what else it could be.

[ Post made via Android ] Image

User avatar
sonoma
Donor
Donor
Posts: 1214
Joined: Sunday, 02 April 2006, 14:10 PM
Location: Oklahoma

Re: Galaxy 2517

Post by sonoma » Sunday, 04 June 2017, 18:04 PM

the rectifier bridge could be bad. did you check the disk caps they mention in the trouble shooting section I sent you here.

[ Post made via Linux Laptop ] Image


User avatar
sonoma
Donor
Donor
Posts: 1214
Joined: Sunday, 02 April 2006, 14:10 PM
Location: Oklahoma

Re: Galaxy 2517

Post by sonoma » Sunday, 04 June 2017, 18:09 PM

they show upgrading tr602 to a different trans and show changing one cap and deleting one for a motor boating noise. that is what most people would call what your radio was doing.

[ Post made via Linux Laptop ] Image

User avatar
sonoma
Donor
Donor
Posts: 1214
Joined: Sunday, 02 April 2006, 14:10 PM
Location: Oklahoma

Re: Galaxy 2517

Post by sonoma » Sunday, 04 June 2017, 18:18 PM

here is more info about the parts in the power supply.

http://www.cbtricks.com/radios/galaxy/d ... ly_sch.gif

[ Post made via Linux Laptop ] Image

User avatar
smoke blower
Skipshooter
Skipshooter
Posts: 341
Joined: Sunday, 26 June 2011, 17:05 PM

Re: Galaxy 2517

Post by smoke blower » Saturday, 10 June 2017, 11:18 AM

I replaced the audio chip with a brand-new one that I ordered. I have very low receive

[ Post made via Android ] Image
Last edited by smoke blower on Saturday, 10 June 2017, 13:15 PM, edited 1 time in total.

User avatar
smoke blower
Skipshooter
Skipshooter
Posts: 341
Joined: Sunday, 26 June 2011, 17:05 PM

Re: Galaxy 2517

Post by smoke blower » Saturday, 10 June 2017, 11:50 AM

I replaced c175 and c179 and still the same

[ Post made via Android ] Image

User avatar
sonoma
Donor
Donor
Posts: 1214
Joined: Sunday, 02 April 2006, 14:10 PM
Location: Oklahoma

Re: Galaxy 2517

Post by sonoma » Saturday, 10 June 2017, 16:16 PM

OK from what I am seeing you have a big problem from the high voltage. did you ever get your self a audio tracer? if not you will have to do a bunch of parts testing. I get it you still do not know how to follow traces of the schematic. here is a few more parts to check, C178, C176, R220, D75. also look at the schematic I sent you at one time that has the traces colored in on a 3600 board. look at the rX one. the part numbers will be different in most cases compared to the board you have but they are all located in the same positions. it should help you to check what parts could be bad. it has the 7222 chip in it. I just looked at it and it will direct you to the parts all associated with the board you have. just look at the 3600 trace then compare it to the 6900 board you have. this will be the only way for you to check parts. if I just look for you it will hender you in learning what to do. if you have a audio tracer you can check all the locations the signal runs into and you will see where the good signal starts and ends.

[ Post made via Linux Laptop ] Image

User avatar
smoke blower
Skipshooter
Skipshooter
Posts: 341
Joined: Sunday, 26 June 2011, 17:05 PM

Re: Galaxy 2517

Post by smoke blower » Saturday, 10 June 2017, 18:00 PM

Unfortunately I have not really learn to read the schematic yet so I will replace the caps you said and see what happens if not I will probably try to find someone that might fix it for me

[ Post made via Android ] Image

User avatar
sonoma
Donor
Donor
Posts: 1214
Joined: Sunday, 02 April 2006, 14:10 PM
Location: Oklahoma

Re: Galaxy 2517

Post by sonoma » Saturday, 10 June 2017, 18:19 PM

if you would look at the schematic I had emailed you it has it colored in so you can follow the traces where they feed the parts in question. Lazarus spent a lot of time drawing them up so a guy could follow all the info for each portion of the rx circuit. he did these just for any one that does not know how to search the schematic. he made them very simple.

[ Post made via Linux Laptop ] Image

User avatar
smoke blower
Skipshooter
Skipshooter
Posts: 341
Joined: Sunday, 26 June 2011, 17:05 PM

Re: Galaxy 2517

Post by smoke blower » Saturday, 10 June 2017, 19:01 PM

ok I will have to find them

User avatar
sonoma
Donor
Donor
Posts: 1214
Joined: Sunday, 02 April 2006, 14:10 PM
Location: Oklahoma

Re: Galaxy 2517

Post by sonoma » Saturday, 10 June 2017, 20:01 PM

I will email the RX schematic again.

[ Post made via Linux Laptop ] Image

User avatar
smoke blower
Skipshooter
Skipshooter
Posts: 341
Joined: Sunday, 26 June 2011, 17:05 PM

Re: Galaxy 2517

Post by smoke blower » Sunday, 18 June 2017, 13:06 PM

I got the receive back Sonoma sorry it took so long to get back to you but c176 was shorted. Now I have to tackle the power supply issue

[ Post made via Android ] Image

User avatar
smoke blower
Skipshooter
Skipshooter
Posts: 341
Joined: Sunday, 26 June 2011, 17:05 PM

Re: Galaxy 2517

Post by smoke blower » Sunday, 18 June 2017, 13:13 PM

I tested tr 602 and it test good

[ Post made via Android ] Image

User avatar
smoke blower
Skipshooter
Skipshooter
Posts: 341
Joined: Sunday, 26 June 2011, 17:05 PM

Re: Galaxy 2517

Post by smoke blower » Sunday, 18 June 2017, 13:19 PM

Also how can I test the rectifier bridge

[ Post made via Android ] Image

User avatar
sonoma
Donor
Donor
Posts: 1214
Joined: Sunday, 02 April 2006, 14:10 PM
Location: Oklahoma

Re: Galaxy 2517

Post by sonoma » Sunday, 18 June 2017, 13:51 PM

C176 was one of the parts I told you to check. glad you found it. the rec is just diodes made together so put you meter on diode check and see if all the legs are working as they should.

[ Post made via Linux Laptop ] Image

User avatar
smoke blower
Skipshooter
Skipshooter
Posts: 341
Joined: Sunday, 26 June 2011, 17:05 PM

Re: Galaxy 2517

Post by smoke blower » Sunday, 18 June 2017, 16:35 PM

I did that and it beeped on two ways but not the other two. I have one here so I might just change it and see what happens. Yes in your last comment you said check c 176 and I did and that was it thank you. I don't know when I will get a chance to work on the power supply probably Friday I am on call this week so probably won't get any time to work on it

[ Post made via Android ] Image

User avatar
sonoma
Donor
Donor
Posts: 1214
Joined: Sunday, 02 April 2006, 14:10 PM
Location: Oklahoma

Re: Galaxy 2517

Post by sonoma » Sunday, 18 June 2017, 17:43 PM

it is just like the main radio board, I can just tell you parts to test and not sure if you know how or not so just make sure you check all in the power supply area. I had a cobra 142 deal me fits a few years ago and it was a bad trans on it. even changed it out and the new one was bad also. which I did not know at the time. anyway the trans was just bad and after I put another new one in it is still working today. did not even think to test it before I put the new trans in place.

[ Post made via Linux Laptop ] Image

User avatar
smoke blower
Skipshooter
Skipshooter
Posts: 341
Joined: Sunday, 26 June 2011, 17:05 PM

Re: Galaxy 2517

Post by smoke blower » Monday, 19 June 2017, 3:54 AM

I bought one of the testers you told me about some time ago that checks transistors, diodes, resistors, capacitor and so on and it is the best thing I ever bought. It tells you bad or unknown part. It shows the transistor to be good

[ Post made via Android ] Image

User avatar
sonoma
Donor
Donor
Posts: 1214
Joined: Sunday, 02 April 2006, 14:10 PM
Location: Oklahoma

Re: Galaxy 2517

Post by sonoma » Monday, 19 June 2017, 4:59 AM

I have a sencore and B&K trans tester and no longer use them since I bought the one you are talking about. it has worked well for me for sure.

[ Post made via Linux Laptop ] Image

User avatar
smoke blower
Skipshooter
Skipshooter
Posts: 341
Joined: Sunday, 26 June 2011, 17:05 PM

Re: Galaxy 2517

Post by smoke blower » Thursday, 22 June 2017, 14:15 PM

I bought a brand new bridge rectifier and still putting out 22volts. I tested both of the transistor and they checked good so what else could it be in the power supply

[ Post made via Android ] Image

User avatar
smoke blower
Skipshooter
Skipshooter
Posts: 341
Joined: Sunday, 26 June 2011, 17:05 PM

Re: Galaxy 2517

Post by smoke blower » Thursday, 22 June 2017, 16:29 PM

Yeah I love the one I bought you told me to get man it checks everything

[ Post made via Android ] Image

User avatar
sonoma
Donor
Donor
Posts: 1214
Joined: Sunday, 02 April 2006, 14:10 PM
Location: Oklahoma

Re: Galaxy 2517

Post by sonoma » Thursday, 22 June 2017, 17:51 PM

if you have tested every part in the power supply I am at a lost as to why it is still so high. you may have to find a complete replacement for the power supply. I sent you a email the other day about this info.

[ Post made via Linux Laptop ] Image

User avatar
smoke blower
Skipshooter
Skipshooter
Posts: 341
Joined: Sunday, 26 June 2011, 17:05 PM

Re: Galaxy 2517

Post by smoke blower » Friday, 23 June 2017, 4:46 AM

Ok I got the info I was just hoping to fix what I have kinda short on money right now. I guess it is only the power supply board or the rectifier that would cause this correct

[ Post made via Android ] Image

User avatar
sonoma
Donor
Donor
Posts: 1214
Joined: Sunday, 02 April 2006, 14:10 PM
Location: Oklahoma

Re: Galaxy 2517

Post by sonoma » Friday, 23 June 2017, 6:48 AM

as far as I can think it would be a part in the power supply.

[ Post made via Linux Laptop ] Image

User avatar
smoke blower
Skipshooter
Skipshooter
Posts: 341
Joined: Sunday, 26 June 2011, 17:05 PM

Re: Galaxy 2517

Post by smoke blower » Friday, 23 June 2017, 17:24 PM

I have replaced ever part in on the power supply board and still 22v

[ Post made via Android ] Image

User avatar
sonoma
Donor
Donor
Posts: 1214
Joined: Sunday, 02 April 2006, 14:10 PM
Location: Oklahoma

Re: Galaxy 2517

Post by sonoma » Friday, 23 June 2017, 18:20 PM

you even changed the rec that converts it to 13.8 volts.I think yours has 4 legs on it.

[ Post made via Linux Laptop ] Image

User avatar
smoke blower
Skipshooter
Skipshooter
Posts: 341
Joined: Sunday, 26 June 2011, 17:05 PM

Re: Galaxy 2517

Post by smoke blower » Friday, 23 June 2017, 18:54 PM

You mean the rectifier I replaced that with a new one. Anyway I went ahead and ordered a new power supply that you sent me from eBay so I will put that in when I get it

[ Post made via Android ] Image

User avatar
sonoma
Donor
Donor
Posts: 1214
Joined: Sunday, 02 April 2006, 14:10 PM
Location: Oklahoma

Re: Galaxy 2517

Post by sonoma » Friday, 23 June 2017, 22:16 PM

you can get those so cheap now. just make sure the one you order is small enough to fit inside where the old one goes.
I have 2 30 amp that I use if I want to use one for a base. works good and can run a small amp off it with the radio.. I have a 14 amp pyramid for my repair bench along with a variable power supply for very low amps to check a radio out during repairs to keep the voltage real low.

[ Post made via Linux Laptop ] Image

User avatar
smoke blower
Skipshooter
Skipshooter
Posts: 341
Joined: Sunday, 26 June 2011, 17:05 PM

Re: Galaxy 2517

Post by smoke blower » Saturday, 24 June 2017, 7:40 AM

Yeah I ordered the one you sent me the picture of I measured the Radio and it should fit good. I should get it next week sometime.

[ Post made via Android ] Image


Post Reply Previous topicNext topic

Who is online

Users browsing this forum: Yahoo [Bot] and 1 guest