Image

galaxy 33 dead

Have some other technical questions can't find the answer for? Come in and ask them here.

Moderator: JR Moderator

User avatar
bluecurt49
4 PILL USER
4 PILL USER
Posts: 21
Joined: Sunday, 28 February 2016, 9:11 AM
Radio: galaxy dx 95t2
Antenna: wilson 5000
Name: curtis

galaxy 33 dead

Post by bluecurt49 » Monday, 20 February 2017, 18:53 PM

the radio does not have any tx or rx, tr 30 has no voltage ive changed tr 36-37 38 still no luck. changed d77 . does any body have an idea


User avatar
295 antenna
Donor
Donor
Posts: 505
Joined: Sunday, 23 October 2016, 21:45 PM
Radio: optima ,cobra 148ex
Antenna: patriot,brownig
Name: Charles Reney

Re: galaxy 33 dead

Post by 295 antenna » Monday, 20 February 2017, 18:58 PM

internal fuse ?
Keep smiling ...It makes people wonder what your up too !

American eagle member : AE1577
TWRC Member : WR2950



User avatar
sonoma
Donor
Donor
Posts: 1307
Joined: Sunday, 02 April 2006, 14:10 PM
Location: Oklahoma

Re: galaxy 33 dead

Post by sonoma » Monday, 20 February 2017, 19:17 PM

just like most of the guys are finding bad solder joints and wire problems even dirty switches on the old radios. check all around the PLL,vco, and audio ic areas. do you even have voltage to the PLL? has some one tried to peak the radio and turned the wrong can and killed the vco area.

User avatar
bluecurt49
4 PILL USER
4 PILL USER
Posts: 21
Joined: Sunday, 28 February 2016, 9:11 AM
Radio: galaxy dx 95t2
Antenna: wilson 5000
Name: curtis

Re: galaxy 33 dead

Post by bluecurt49 » Monday, 20 February 2017, 19:58 PM

I do have voltage at the pll and I have checked all around the audio- vco -pll areas no bad solder joints.replaced audio chip and d78 still no change

User avatar
sonoma
Donor
Donor
Posts: 1307
Joined: Sunday, 02 April 2006, 14:10 PM
Location: Oklahoma

Re: galaxy 33 dead

Post by sonoma » Monday, 20 February 2017, 20:09 PM

have you made sure the PLL is locked as I mentioned and 10.240 at the PLL and crystal.verify the vco is locked if you are sure there is no bad solder joints. did you check them in those areas with a good magnifying glass so they come in good. I even use a microscope to get a goos look at the joints to see for bad solder. some I will hit them if they look slightly bad. can not even start to say how many over the years came back after touching up solder. also make sure the controls on the front of the radio are clean. they can kill a radio at times when they are dirty. just got a galaxy 44 going off ebay for bad controls . after cleaning the controls the 44 came back to life. a tech had checked it from what the ebay seller said when he sold it. bought it for 25.00 shipped due to a tech telling him it was not repairable.


User avatar
bluecurt49
4 PILL USER
4 PILL USER
Posts: 21
Joined: Sunday, 28 February 2016, 9:11 AM
Radio: galaxy dx 95t2
Antenna: wilson 5000
Name: curtis

Re: galaxy 33 dead

Post by bluecurt49 » Tuesday, 21 February 2017, 5:30 AM

Thais I'll try again

User avatar
sonoma
Donor
Donor
Posts: 1307
Joined: Sunday, 02 April 2006, 14:10 PM
Location: Oklahoma

Re: galaxy 33 dead

Post by sonoma » Tuesday, 21 February 2017, 6:19 AM

there is more to this than just saying you have voltages to it. you need correct voltages. here is a link to a galaxy 33 that has the service manual and it has two or three pages with voltages that are about normal for each part inside the radio. you can have voltages every where but if they are not correct you are just wasting you time checking and not getting the proper voltages to each leg of a part.

http://www.cbtricks.com/radios/galaxy/dx33hml/index.htm" onclick="window.open(this.href);return false;


Post Reply Previous topicNext topic

Who is online

Users browsing this forum: No registered users and 1 guest