Image

Stryker SR-89MC squeal

This is the place to post your general tips, or need to have a question on your install here.

Moderator: JR Moderator

User avatar
Hickey
NEW DUCK
NEW DUCK
Posts: 2
Joined: Thursday, 17 February 2011, 19:55 PM
Radio: Galaxy DX 88HL
Antenna: hustler hq-27
Name: Jeremy

Stryker SR-89MC squeal

Post by Hickey » Monday, 21 September 2015, 19:39 PM

I ordered one of these out of Florida last week. Installed it and I've got a wicked bad squeal through my stereo. It only happens with the stereo on. I can also hear my voice over the stereo speakers.
I Googled some, and most people (who didn't jump and yell "illegal!") pointed to a ground issue. I've tried several grounds and nothing has changed. Thing is, I've got it installed in the exact same way as my Galaxy 94hp in my work truck. I just unhooked the galaxy and hooked this up to everything the same way. I've been running the galaxy in this truck for 640k miles with not a single issue.

Any ideas?


User avatar
1206FL
Wordwide & Qualified
Wordwide & Qualified
Posts: 574
Joined: Friday, 30 January 2015, 3:23 AM

Re: Stryker SR-89MC squeal

Post by 1206FL » Tuesday, 22 September 2015, 3:19 AM

It is not a ground issue its most likely RF getting back into the stereo. Try placing some ferrite snap on chokes to your coax at the feed point and at the stereo speakers. Did you have the radio on while using the 94hp as well? Sounds like your new radio has been peaked and tweaked! How many watts out? What is the vswr at with new radio? May be other issues than just stray RF but that is what it sounds like to me. Grounding is important. How is your ground ran currently? You may have to either A- take both + & - leads to your batt. Or B- make ground as short as possible and try to ground to frame like on a seat bolt or under the dash at the steering column. And you can add a ground loop isolator onto the power and ground leads. Check with the site sponsors as they may sell them. Also where is the head of the new radio placed? This may be causing your issue of it's too close to the radio or near any of the speaker wires. Try moving the head unit away from all wiring and stereo as far as possible and see what happens. Might help, might not. Hopefully you'll get it resolved and don't let a few butt holes ruin you're experience!!! Good luck and hope some of this info might help.

User avatar
MDYoungblood
Moderator
Moderator
Posts: 7402
Joined: Saturday, 12 June 2010, 19:05 PM
Logged in via: iPhone
Radio: Uniden Washington
Antenna: Avanti Sigma II
Name: Greg
Location: Baltimore, MD
Contact:

Re: Stryker SR-89MC squeal

Post by MDYoungblood » Saturday, 31 October 2015, 10:04 AM

The Stryker SR-89MC is basically 2 units, the hand unit and the main unit. The hand unit doesn't produce any RF so it couldn't be that. When you installed the ground (a wire from a case screw to metal body) did you run it to metal and not to the black/negative connection. The next thing to try is move the main unit farther away from the stereo head unit. Last thing to try is snap ferrites on the speaker wiring. Other then the squeal have you had any other issues with the Stryker?

3's

Greg
"321, the Middle of Maryland"

23 AM "WORLD WIDE" 38 LSB

Strong Supporter of America's Original Homeland Security Act
The Second Amendment



Official Moderator - CBRT Complaint Department




Post Reply Previous topicNext topic

Who is online

Users browsing this forum: No registered users and 1 guest